A payment is not syncing to an invoice in ConnectWise PSA.

 

Cause

It is likely that the "Last Ran" date/time recorded for the Payment Sync is more recent than the Last Modified date on the payment in question in QuickBooks Online. If the Last Modified date on the payment in QuickBooks Online is prior to the Last Run date on the Payment Sync, then the payment is is not being seen.

Example

If the Payment Sync has a Last Ran date of March 31, then next time it runs, it will only look for payments after that date, i.e. April 1 and beyond. If the Last Modified date on the payment in QuickBooks Online is dated March 28, then it is not being seen by the sync process. This could possibly occur if a QuickBooks Online Configuration in the integration was deleted/recreated.

Resolution

Single Payment is affected

Nonetheless, every time you click "save" on an element in QuickBooks Online, Intuit refreshes the "Last Modified" date on that transaction, which is the date that the integration is using to find new information. So, by opening the payment in QuickBooks Online and simply clicking "save", Intuit will update the Last Modified date, putting it back into a range that will be seen by the Payment Sync feature.

Multiple Payments are affected

 

  1. Select Run New Batch
  2. Run Payment Sync
  3. Select a start date before the missing payment
  4. Select Submit
By back dating your payment sync, all payments within the sync parameters (the date selected - current date) will be removed and reapplied in ConnectWise PSA. This process can take longer than a normal payment sync depending on the number of payments that are affected.

 







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